AXZ博客
给你海洋的知识 AXZLK.COM!

易语言怎么获取网页指定文本内容(python提取文本指定内容)

易语通过百度获取北京时间 易语通过百度错误页面获取北京时间的代码

易语言源码教程2021-03-30

使用百度获取北京时间源码

.版本 2
.程序集 窗口程序集1
.子程序 __启动窗口_创建完毕
.局部变量 XML对象, 对象
.局部变量 时间文本, 文本型
.局部变量 网络时间, 日期时间型
.如果真 (XML对象.创建 (“WinHttp.WinHttpRequest.5.1”, ))
  XML对象.方法 (“SetTimeouts”, 5000, 5000, 10000, 5000)
  XML对象.写属性 (“Option”, 6, 0)

易语言怎么获取网页指定文本内容_python提取文本指定内容_易语言取网页指定文本

XML对象.方法 (“open”, “HEAD”, “http://www.baidu.com/jb51.net”, 假) XML对象.方法 (“send”, ) 时间文本 = XML对象.读属性 (“GetResponseHeader”, “Date”).取文本 () .如果真结束 网络时间 = 时间格式化 (时间文本) 时间编辑框.内容 = 到文本 (时间文本) + #换行符 + 到文本 (网络时间) .子程序 时间格式化, 日期时间型 .参数 时间文本, 文本型 .局部变量 临时数组, 文本型, , "0" .局部变量 临时变量, 文本型 .局部变量 时间变量, 日期时间型 .局部变量 临时时间, 日期时间型 .局部变量 日, 文本型

python提取文本指定内容_易语言取网页指定文本_易语言怎么获取网页指定文本内容

.局部变量 月, 文本型 .局部变量 年, 文本型 .局部变量 时, 文本型 .局部变量 分, 文本型 .局部变量 秒, 文本型 临时数组 = 分割文本 (时间文本, “, ”, ) 临时变量 = 临时数组 [2] 临时变量 = 子文本替换 (临时变量, “ GMT”, , , , 真) 清除数组 (临时数组) 临时数组 = 分割文本 (临时变量, “ ”, ) 日 = 临时数组 [1] .判断开始 (临时数组 [2] = “Jan”) 月 = “01”

python提取文本指定内容_易语言取网页指定文本_易语言怎么获取网页指定文本内容

.判断 (临时数组 [2] = “Feb”) 月 = “02” .判断 (临时数组 [2] = “Mar”) 月 = “03” .判断 (临时数组 [2] = “Apr”) 月 = “04” .判断 (临时数组 [2] = “Mar”) 月 = “05” .判断 (临时数组 [2] = “Jun”) 月 = “06” .判断 (临时数组 [2] = “Jul”) 月 = “07” .判断 (临时数组 [2] = “Aug”)

易语言取网页指定文本_python提取文本指定内容_易语言怎么获取网页指定文本内容

月 = “08” .判断 (临时数组 [2] = “Sep”) 月 = “09” .判断 (临时数组 [2] = “Oct”) 月 = “10” .判断 (临时数组 [2] = “Nov”) 月 = “11” .判断 (临时数组 [2] = “Dec”) 月 = “12” .默认 .判断结束 年 = 临时数组 [3] 临时变量 = 临时数组 [4]

易语言怎么获取网页指定文本内容_python提取文本指定内容_易语言取网页指定文本

清除数组 (临时数组) 临时数组 = 分割文本 (临时变量, “:”, ) 时 = 到文本 (到整数 (临时数组 [1])) 分 = 临时数组 [2] 秒 = 临时数组 [3] 时间变量 = 到时间 (年 + “/” + 月 + “/” + 日 + “/” + 时 + “/” + 分 + “/” + 秒) 时间变量 = 增减时间 (时间变量, #小时, 8) 返回 (时间变量)

运行结果:

易语言怎么获取网页指定文本内容_易语言取网页指定文本_python提取文本指定内容

总结

以上就是本文的全部内容。 希望本文的内容对您的学习或工作有一定的参考价值。 感谢您的支持,如果您想了解更多相关内容易语言怎么获取网页指定文本内容易语言怎么获取网页指定文本内容,请查看下方相关链接

编者按:【腾讯云】爆款云服限时体验20元起,更多云必备品低至1元

相关文章

赞(0)
未经允许不得转载:AXZ博客 » 易语言怎么获取网页指定文本内容(python提取文本指定内容)
分享到

评论 抢沙发

登录

找回密码

注册